[solved] netbeans api transitive module problem

If you meet this, you just forget to add the dependency to pom.xml, so in my case i just add org-netbeans-api-java-classpath then this problem gone.

Project uses classes from transitive module org.netbeans.api:org-netbeans-api-java-classpath:jar:RELEASE82 which will not be accessible at runtime.
To fix the problem, add this module as direct dependency. For OSGi bundles that are supposed to be wrapped in NetBeans modules, use the useOSGiDependencies=false parameter

read count : 3